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1 Introduction

High speed photography makes special demands to the photographer and his equipment. The events which should be 
fixed are running in extreme short periods in the area from milli- or microseconds and are not visible for the sluggishly 
human eye. 

Example of high speed events of the daily life:

• Bursting balloon

• objects falling to the ground and burst 

• object falling into a liquid

• waterdrops

• impact of a gun bullet into an object 

Within this part of photography it is absolute necessary to find the one right moment of the photography and this by a 
very short lightning time (1/1000 to 1/30.000 second) for freezing the event. 

What is Droplet?

Droplet is a tool collection for the microcontroller supported high speed photography with special attention on the 
drop photography and liquid art. By the help of the microcontroller many of different equipments are steered exactly 
for the millisecond and combined for a defined workflow. 
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2 Installation

Prerequisites

For using of Droplet you need the following:

• Arduino microcontroller (for more information look at http://arduino.cc) 

• USB cable A/B for connecting the pc with the microcontroller

• Microcontroller steered equipment which (for example solenoid valves, flash light , cameras, …) 

Mac OS X

System requirements

1. for Droplet’s current  version  at least is recommended Mac OS X 10.5 (Leopard)

2. Java installed Java Runtime Environment (JRE) version 1.6 or higher

Install Droplet

One double click on the downloaded image file (dmg) activates the package as a new volume and a finder-window 
with the Droplet’s program-icon appears.

Now move the program with the mouse in the „Applications“ place.
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Afterwards cast the image.

Launch Droplet

You start Droplet by a double click on the program icon.

Windows

System requirements

1. Windows XP, Windows Vista or Windows 7

2. Java – installed Java Runtime Environment (JRE) version 1.6 or higher 

Install Droplet

For installation please execute the Setup file. If you have installed a 32bit Java, please use setup_x86.exe and if you 
have installed an 64bit Java use setup_x64.exe. To find out which version of Java is installed please proceed as follows:
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Select the place on your pc at which Droplet shall be installed. Afterwards you can produce an entry for Droplet in 
Windows Startup menu. From this place you are able to start Droplet comfortably.

Click on installing and wait until the installation process is ended. This should not last longer than a view seconds.

Congratulations, you have installed Droplet on your system successfully and you are now able to use it. 

Launch Droplet

The easiest way to start Droplet is to start it from Windows StartupMenu. Click on the link Droplet. After a few 
moments the main screen of Droplet should appear.

Linux

Until now Droplet has not been tested under Linux.

Arduino

System requirements

1. Arduino IDE (recommended is at least version 1.0)

2. Droplet Arduino Sketch (included) or

3. crazyMachine as of version 0.3a (optional) 

Droplet Arduino Sketch

Droplet is delivered with a ready to use Arduino sketch, which you upload to your Arduino microcontroller and with 
Droplet you are able to control it by your pc. This sketch is made for the special dynamic claims of Droplet and 
(theoretically) arbitrarily much equipment can be controlled with it. The actual number depends on the used 
Arduinoboard.

Arduino Board Possible devices Amount actions per device

Arduino Nano
(ATMega168)

14 ca. 5 (1KB)

Arduino Nano
(ATMega328)

14 ca. 10 (2KB)

Arduino Uno
(ATMega328)

14 ca. 10 (2KB)

Arduino Duemilanova
(ATMega168 or ATMega328)

14
ca. 3 (1KB) (ATMega168)
ca. 5 (2KB) (ATMega328)

Arduino Mega 2560
(ATMega2560)

54 ca. 30 (8KB)
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HINT | I assume that you know how an Arduino Sketch is uploaded to a Arduino Board. Further informations about 
this topic you will find under http://arduino.cc/en/Guide/HomePage

Unpack the enclosed zipfile sketch_droplet.zip, open the sketch in the Arduino IDE and afterwards upload it to your 
Arduino board. To test if the upload was successful, you can open the serial monitor in the Arduino IDE and send the 
character string H;13 to the board. Pay attention that the data rate is 9600 baud and that the character string is ending 
with newline (see Illustration 1: Serial Monitor – Connection test). Afterwards the small orange led which is coupled to 
the pin 13 should shine. With the character string L;13 you can switch off the led.

You have done it and now you are able to steer your Arduino Board with the help of Droplet.

crazyMachine

Alternatively you can steer the crazyMachine developed by Nicolai Korff by Droplet. Exact informations about it you 
find under http://crazymachine.nicolai-korff.de

Source Code

Droplet is a open source project on GitHub. If you like to participate at the project you can download the sourcecode 
at https://github.com/fuxi83/Droplet.

Error handling

Copyright © 2013 Stefan Brenner. All Rights Reserved. 9
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3 Introduction to Droplet

Droplet’s user interface consists of the sections communication, device setup, processing, logging and the toolbar. The 
elements of the surface and their functionality are described in the following chapter. 

Communication

In this section the connection to the microcontroller is done. Choose from the list of all serial interfaces the one 
connected to the microcontroller. Beside the list is shown the actual status of the connection.

ATTENTION | The microcontroller must be connected before Droplet is started.

Device Setup

This is the main section of Droplet where the equipment and actions can be defined and configured. With Droplet a 
unlimited number of equipment and each with a unlimited number of actions can be configured. By the way the 
following equipment and action types are distinguished:

Device Type Action Type Relevance

Valve Offset / Duration A valve can be opened at a defined offset for a defined duration

Flash Offset A flash can be released at a defined offset

Camera Offset / Duration
A camera can be released at a defined offset for a defined duration. 
That ensures that the continuing shooting mode of the camera can be 
used.

All time data in Droplet are done in milliseconds (1000ms = 1sec).

Time management

Using an example the different possibilities of the time management with Droplet are represented.

10 Chapter 3 Introduction to Droplet
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Example 1)

The example setup contains two valves and one camera. The accompanying equipment setup is shown in illustration 3 
and the accompanying time diagram can be seen in illustration 4. 

Workflow description:

• The first valve opens at the start of the run. Then it is opened for a duration of 130 ms and is then closed. 

After another 30 ms the first valve opens again and this time it is open for a duration of 50 ms.

• The second valve opens 60 ms after start of the process and is open for a duration of 100 ms.

• The camera triggers after 250 ms after the start for a duration of 100 ms.

Copyright © 2013 Stefan Brenner. All Rights Reserved. 11
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Shutter impuls of the camera

To ensure a reliable triggering of the camera it is necessary to intend the end solving impulse for a maintaining time. 
This duration is different for every camera model. Becomes this duration at least to low the camera ignores the 
impulse and solves correspondingly not fallen.

INFORMATION | If you have problems releasing your camera, check if you set enough time for the shutter impuls.

In the following you find a survey of collected empirical values and end solving impulses which are required of 
different camera models: 

Camera
required 

shutter impuls (ms)

Pentax K-5 300

Canon EOS 7D 100

Pre-focusing of the camera

Besides the compliance with the required duration for the shutter impulse of a camera under circumstances it can also 
be necessary, to send a second impulse befor sending the shutter impulse to ensure a correct shutter release. 

By the connector of the cable release of the modern DSLR the autofocus and. If an impuls is send to autofocus the 
camera tries ( if the lens of the camera is in AF mode) to put keenly on the object. Only if this process is ended 
successfully by another impuls the shutter will released. 

At some camera models it can be necessary that pre-focusing impulse is sent also if the camera is in MF mode. 
Without this impulse the camera would not release the shutter. In picture 13 there is a configuration of pre-focusing of 
the camera. 

ATTENTION | Although the camera/lens is set to MF mode, it may be neccessary to use pre-focusing to ensure that 
the camera can be released!
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Processing
In this section the automatic award of metadata to the produced pictures can be activated. There comments and 
keywords can be allocated. In addition the configured times can be written un the metadata. In table 1 you see the 
fields keywords and description in the metadata of a picture filled suitably for illustration 6. 

Keywords
(IPTC Core)

Orange, Blau

Description
(IPTC Core)

1/2l Wasser, 1/2TL GK-Mehl, Ventil 40cm, 
Behaelter 120cm

This picture was created with the help of Droplet - 
Toolkit for Liquid Art Photographer
Droplet Serial Communication Protocol
S;2;V;0|82;147|90^319
S;6;C;280|100^380

Table 1: metadata of the picture
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Functioning

The metadata are not directly stored into the image files but in the XMP ((Extensible Metadata platform) files with the 
same name like the image files have and with .xmp ending. These metadata can then be read and processed by other 
programs ( like  Adobe Bridge, Adobe Photoshop Lightroom, Aperture, …). 

Filename Content

20120101_Bild-01.CR2 Original image file

20120101_Bild-01.xmp Metadaten for the image

Droplet is now able to supervise a folder and for every new image file added to this folder a XMP file is added into this 
folder. There fort he supervised folder must be defined in field Watch Folder.

ATTENTION | the automatic award of metadata only works, if images are directly submitted by remoteshooting to the 
PC and the target folder location is configures in Droplet as a monitored folder!

Example: Workflow in connection with Adobe Photoshop Lightroom

In the following an example workflow is shown of the use of the automatic metadata award into combination with it 
Remote Shooting and Adobe Photoshop Lightroom.

1. camera shutter releases

2. RAW/JPEG imageis saved in folder /Pictures/remote

3. Droplet  recognizes that a new picture in the folder /Pictures/remote

4. Droplet  builds a XMP file with same name as the original image in folder /Pictures/remote

5. Lightroom recognizes that a new image is available in folder /Pictures/remote

6. Lightroom moves the new image incl. the accompanying XMP file into the target folder                          
/Pictures/library/Auto Imported Photos and imports the image inclusive metadata in the catalog

7. After that the image can quit normally be processed in Lightroom
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Logging
Here are presented the most important news and reports including timestamps. With the help of the button Ent or Del 
the contents of the message console can be emptied. 

Toolbar
From here you can control the important actions of Droplet:

• Control Devices  : opens a dialog where the defined parameters of the defined device can be changed. Also 

each device may be directly switched on and off. This may be useful for cleaning a solenoid valve or for testing 
a flashlight and to release the camera shutter. You the device number can be declared for identification.

• Show  : gibt die aktuelle Konfiguration des Mikrocontrollers in der Nachrichtenkonsole aus

• Send  : sends the current device configuration to the micro controller

• Start  : startet die in Runden definierte Anzahl an Ausführungen. Wenn mehr als eine Runde ausgeführt 

werden soll, kann zusätzlich noch eine Verzögerung definiert werden. Diese gibt an, wie viel Millisekunden 
zwischen den Ausführungen der einzelnen Runden pausiert werden soll.

• Cancel  : is stopping the running Operation after having done the actual round

Copyright © 2013 Stefan Brenner. All Rights Reserved. 15
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Preferences

In the settings of Preferences of von Droplet the used communication service and new protocol can be defined.

The communication service is responsible for the communication between Droplet und microcontroller. In version 0.1 
only the Arduino is supported. 

The event protocol is controlling the event, which is transfered between Droplet and the microcontroller. In version 0.1 
is only supported the Droplet Serial Communication Protocol (see chapter 17).

Shortcuts

You find here a listing of the most important key combinations:

Tastenkürzel Menü Aktion

⌘ + N File → New New Droplet configuration

⌘ + O File → Load... Load Droplet configuration

⌘ + S File → Save Save current configuration

⌘ + Shift + S File → Save As... Save current configuration as

⌘ + Q File → Exit Exit Droplet

F1 Help → About Show the help

F3 Edit → Add device Add new device

F4 Start

⌘ + , Edit → Preferences Droplet Preferences
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4 Droplet Serial Communication Protocol (DSCP)

For the communication between Droplet and the microcontroller the Droplet serial communication protocol was 
developed. Under consideration of the special requirements on a serial communication with the microcontroller and 
to make the character string to be transported as short and efficient as possible.

Befehl Bedeutung

Set Send a configuration to the micro controller

Release Start the configuration

High Switch ON a device connected to the micro controller

Low Switch OFF a device connected to the micro controller

Info Get information about the current configuration

Reset Reset microcontroller

Definition of DSCP in EBNF

Protocol = SetCommand | ReleaseCommand | HighCommand | LowCommand | "I" | "X" ;

SetCommand = "S" FieldSeparator DeviceConfig ;

ReleaseCommand = "R" Number [ FieldSeparator Number ] ;

HighCommand = "H" FieldSeparator DeviceNumber ;

LowCommand = "L" FieldSeparator DeviceNumber ;

DeviceConfig = DeviceNumber FieldSeparator Device FieldSeparator Times ChksumSeparator Chksum ;

DeviceNumber = DigitWithoutZero ;

Device = "V" | "F" | "C" ;

Times = Time { FieldSeparator Time } ;

Time = Offset TimeSeparator Duration ;

Offset = Number ;

Duration = Number ;

Chksum = Number ;

FieldSeparator = ";" ;

TimeSeperator = "|" ;

ChksumSeparator = "^" ;

Number = DigitWithoutZero { Digit } ;

DigitWithoutZero  = "1" | "2" | "3" | "4" | "5" | "6" | "7" | "8" | "9" ;

Digit = "0" | DigitWithoutZero ;
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